English

I would like to play LEGO Star Wars II: The Original Trilogy on OS X 10.3 Can I do this?

No. LEGO Star Wars II: The Original Trilogy is only compatible with OS X 10.4 and later.